#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(black\n{\n.*\n\s*value\s+)\d+"
Local $sString = "black" & @CRLF & _
"{" & @CRLF & _
" part cone;" & @CRLF & _
" value 20;" & @CRLF & _
"}" & @CRLF & _
"yellow" & @CRLF & _
"{" & @CRLF & _
" part wing;" & @CRLF & _
" value 30;" & @CRLF & _
"}"
Local $sSubst = "\g<1>30"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)