re = /(?m)^(black\n{\n.*\n\s*value\s+)\d+/
str = 'black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}'
subst = '\\g<1>30'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result