import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(black\\n\\{\\n.*\\n\\s*value\\s+)\\d+";
final String string = "black\n"
+ "{\n"
+ " part cone;\n"
+ " value 20;\n"
+ "}\n"
+ "yellow\n"
+ "{\n"
+ " part wing;\n"
+ " value 30;\n"
+ "}";
final String subst = "\\g<1>30";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}