package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(black\n{\n.*\n\s*value\s+)\d+`)
var str = `black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}`
var substitution = "\g<1>30"
fmt.Println(re.ReplaceAllString(str, substitution))
}