import Foundation
let pattern = #"(?m)^(black\n{\n.*\n\s*value\s+)\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<1>30"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)