const regex = new RegExp('(?m)^(black\\n{\\n.*\\n\\s*value\\s+)\\d+', 'g')
const str = `black
{
part cone;
value 20;
}
yellow
{
part wing;
value 30;
}`;
const subst = `\g<1>30`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);