# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a.*href="#".*>)(.*)(<\\/a>)/$2/guU;t' <<< "<a href=\"#\" target=\"_blank\"></a>
<a style=\"\" href=\"bla-bla-bla\">тег, который нужно оставить</a>
<a href=\"#\"></a>
<a style=\"\" href=\"#\">Тут текст который нужно оставить, а сам тег а удалить</a><a style=\"\" href=\"bla-bla-bla\">тег, который нужно оставить</a>
<a href=\"#\">Тут текст который нужно оставить, а сам тег а удалить</a>"