import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a.*href=\"#\".*>)(.*)(<\\/a>)";
final String string = "<a href=\"#\" target=\"_blank\"></a>\n"
+ "<a style=\"\" href=\"bla-bla-bla\">тег, который нужно оставить</a>\n"
+ "<a href=\"#\"></a>\n"
+ "<a style=\"\" href=\"#\">Тут текст который нужно оставить, а сам тег а удалить</a><a style=\"\" href=\"bla-bla-bla\">тег, который нужно оставить</a>\n"
+ "<a href=\"#\">Тут текст который нужно оставить, а сам тег а удалить</a>";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}