$re = '/(<a.*href="#".*>)(.*)(<\/a>)/uU';
$str = '<a href="#" target="_blank"></a>
<a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#"></a>
<a style="" href="#">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#">Тут текст который нужно оставить, а сам тег а удалить</a>';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;