re = /(<a.*href="#".*>)(.*)(<\/a>)/
str = '<a href="#" target="_blank"></a>
<a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#"></a>
<a style="" href="#">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#">Тут текст который нужно оставить, а сам тег а удалить</a>'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result