package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(<a.*href="#".*>)(.*)(<\/a>)`)
var str = `<a href="#" target="_blank"></a>
<a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#"></a>
<a style="" href="#">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#">Тут текст который нужно оставить, а сам тег а удалить</a>`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}