use strict;
my $str = '<a href="#" target="_blank"></a>
<a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#"></a>
<a style="" href="#">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#">Тут текст который нужно оставить, а сам тег а удалить</a>';
my $regex = qr/(<a.*href="#".*>)(.*)(<\/a>)/up;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";