using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a.*href=""#"".*>)(.*)(<\/a>)";
string substitution = @"$2";
string input = @"<a href=""#"" target=""_blank""></a>
<a style="" href=""bla-bla-bla"">тег, который нужно оставить</a>
<a href=""#""></a>
<a style="" href=""#"">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href=""bla-bla-bla"">тег, который нужно оставить</a>
<a href=""#"">Тут текст который нужно оставить, а сам тег а удалить</a>";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}