import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = ##"(<a.*href="#".*>)(.*)(<\/a>)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<a href="#" target="_blank"></a>
<a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#"></a>
<a style="" href="#">Тут текст который нужно оставить, а сам тег а удалить</a><a style="" href="bla-bla-bla">тег, который нужно оставить</a>
<a href="#">Тут текст который нужно оставить, а сам тег а удалить</a>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)