#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<at\s)"
Local $sString = "<at id="user-01">Jonh</at> in group <at id="group-02">Android</at>"
Local $sSubst = "\1onclick="clickMention(this.id)" "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)