$re = '/(<at\s)/m';
$str = '<at id="user-01">Jonh</at> in group <at id="group-02">Android</at>';
$subst = "\1onclick=\"clickMention(this.id)\" ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;