import re
regex = re.compile(r"(<at\s)", flags=re.MULTILINE)
test_str = "<at id=\"user-01\">Jonh</at> in group <at id=\"group-02\">Android</at>"
subst = "\\1onclick=\"clickMention(this.id)\" "
result = regex.sub(subst, test_str)
if result:
print(result)