const regex = /(<at\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<at\\s)', 'gm')
const str = `<at id="user-01">Jonh</at> in group <at id="group-02">Android</at>`;
const subst = `\1onclick="clickMention(this.id)" `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);