import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<at\\s)";
final String string = "<at id=\"user-01\">Jonh</at> in group <at id=\"group-02\">Android</at>";
final String subst = "\\1onclick=\"clickMention(this.id)\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}