# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a\s+href=")(.*?)(">)(.*?)(<\\/a>)/\1\2\/\4\3\4\5/gm;t' <<< "<a href=\"http://domain.com/5et46ffd5e3wR23\">anchor1.in</a>
<a href=\"http://domain.com/6utr4dGHJ6wFL\">an3.php</a>
<a href=\"http://domain.com/k543sk6k3F6hJ\">setup.exe</a>"