use strict;
my $str = '<a href="http://domain.com/5et46ffd5e3wR23">anchor1.in</a>
<a href="http://domain.com/6utr4dGHJ6wFL">an3.php</a>
<a href="http://domain.com/k543sk6k3F6hJ">setup.exe</a>';
my $regex = qr/(<a\s+href=")(.*?)(">)(.*?)(<\/a>)/mp;
my $subst = '\\1\\2/\\4\\3\\4\\5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";