const regex = /(<a\s+href=")(.*?)(">)(.*?)(<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a\\s+href=")(.*?)(">)(.*?)(<\\\/a>)', 'gm')
const str = `<a href="http://domain.com/5et46ffd5e3wR23">anchor1.in</a>
<a href="http://domain.com/6utr4dGHJ6wFL">an3.php</a>
<a href="http://domain.com/k543sk6k3F6hJ">setup.exe</a>`;
const subst = `\1\2/\4\3\4\5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);