$re = '/(<a\s+href=")(.*?)(">)(.*?)(<\/a>)/m';
$str = '<a href="http://domain.com/5et46ffd5e3wR23">anchor1.in</a>
<a href="http://domain.com/6utr4dGHJ6wFL">an3.php</a>
<a href="http://domain.com/k543sk6k3F6hJ">setup.exe</a>';
$subst = "\1\2/\4\3\4\5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;