using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\s+href="")(.*?)("">)(.*?)(<\/a>)";
string substitution = @"\1\2/\4\3\4\5";
string input = @"<a href=""http://domain.com/5et46ffd5e3wR23"">anchor1.in</a>
<a href=""http://domain.com/6utr4dGHJ6wFL"">an3.php</a>
<a href=""http://domain.com/k543sk6k3F6hJ"">setup.exe</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}