import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a\\s+href=\")(.*?)(\">)(.*?)(<\\/a>)";
final String string = "<a href=\"http://domain.com/5et46ffd5e3wR23\">anchor1.in</a>\n"
+ "<a href=\"http://domain.com/6utr4dGHJ6wFL\">an3.php</a>\n"
+ "<a href=\"http://domain.com/k543sk6k3F6hJ\">setup.exe</a>";
final String subst = "\\1\\2/\\4\\3\\4\\5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}