package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a\s+href=")(.*?)(">)(.*?)(<\/a>)`)
var str = `<a href="http://domain.com/5et46ffd5e3wR23">anchor1.in</a>
<a href="http://domain.com/6utr4dGHJ6wFL">an3.php</a>
<a href="http://domain.com/k543sk6k3F6hJ">setup.exe</a>`
var substitution = "\1\2/\4\3\4\5"
fmt.Println(re.ReplaceAllString(str, substitution))
}