// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<a\s+href=")(.*?)(">)(.*?)(<\/a>)"#).unwrap();
let string = "<a href=\"http://domain.com/5et46ffd5e3wR23\">anchor1.in</a>
<a href=\"http://domain.com/6utr4dGHJ6wFL\">an3.php</a>
<a href=\"http://domain.com/k543sk6k3F6hJ\">setup.exe</a>";
let substitution = "\\1\\2/\\4\\3\\4\\5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}