#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<a\s+href=")(.*?)(">)(.*?)(<\/a>)"
Local $sString = "<a href="http://domain.com/5et46ffd5e3wR23">anchor1.in</a>" & @CRLF & _
"<a href="http://domain.com/6utr4dGHJ6wFL">an3.php</a>" & @CRLF & _
"<a href="http://domain.com/k543sk6k3F6hJ">setup.exe</a>"
Local $sSubst = "\1\2/\4\3\4\5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)