# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a\s+href=\")(.*?)(\">)(.*?)(<\/a>)"
test_str = ("<a href=\"http://domain.com/5et46ffd5e3wR23\">anchor1.in</a>\n"
"<a href=\"http://domain.com/6utr4dGHJ6wFL\">an3.php</a>\n"
"<a href=\"http://domain.com/k543sk6k3F6hJ\">setup.exe</a>")
subst = "\\1\\2/\\4\\3\\4\\5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.