using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",?\+\d+_[^,]+";
string substitution = @"";
string input = @"+1223,+12_remove_me,+222,+2223_remove_me";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}