package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`,?\+\d+_[^,]+`)
var str = `+1223,+12_remove_me,+222,+2223_remove_me`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}