// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r",?\+\d+_[^,]+").unwrap();
let string = "+1223,+12_remove_me,+222,+2223_remove_me";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}