re = /,?\+\d+_[^,]+/
str = '+1223,+12_remove_me,+222,+2223_remove_me'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result