$re = '/,?\+\d+_[^,]+/';
$str = '+1223,+12_remove_me,+222,+2223_remove_me';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;