import re
regex = re.compile(r",?\+\d+_[^,]+")
test_str = "+1223,+12_remove_me,+222,+2223_remove_me"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)