# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^1(?:(222)|(333)|(444))$/89${1:+777}${2:+666}${3:+555}/gm;t' <<< "1222
1333
1444
1234
122234567"