const regex = /^1(?:(222)|(333)|(444))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^1(?:(222)|(333)|(444))$', 'gm')
const str = `1222
1333
1444
1234
122234567`;
const subst = `89${1:+777}${2:+666}${3:+555}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);