import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1(?:(222)|(333)|(444))$";
final String string = "1222\n"
+ "1333\n"
+ "1444\n"
+ "1234\n"
+ "122234567";
final String subst = "89${1:+777}${2:+666}${3:+555}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}