# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^1(?:(222)|(333)|(444))$"
test_str = ("1222\n"
"1333\n"
"1444\n"
"1234\n"
"122234567")
subst = "89${1:+777}${2:+666}${3:+555}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.