package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1(?:(222)|(333)|(444))$`)
var str = `1222
1333
1444
1234
122234567`
var substitution = "89${1:+777}${2:+666}${3:+555}"
fmt.Println(re.ReplaceAllString(str, substitution))
}