// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^1(?:(222)|(333)|(444))$").unwrap();
let string = "1222
1333
1444
1234
122234567";
let substitution = "89${1:+777}${2:+666}${3:+555}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}