#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^1(?:(222)|(333)|(444))$"
Local $sString = "1222" & @CRLF & _
"1333" & @CRLF & _
"1444" & @CRLF & _
"1234" & @CRLF & _
"122234567"
Local $sSubst = "89${1:+777}${2:+666}${3:+555}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)