$re = '/^1(?:(222)|(333)|(444))$/m';
$str = '1222
1333
1444
1234
122234567';
$subst = "89${1:+777}${2:+666}${3:+555}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;