use strict;
my $str = '1222
1333
1444
1234
122234567';
my $regex = qr/^1(?:(222)|(333)|(444))$/mp;
my $subst = '89${1:+777}${2:+666}${3:+555}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";