using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1(?:(222)|(333)|(444))$";
string substitution = @"89${1:+777}${2:+666}${3:+555}";
string input = @"1222
1333
1444
1234
122234567";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}