using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<)(br|div)([^>]+?)(\/?\s*>)";
string substitution = @"\1\2\4";
string input = @"<br id=""foo"" style=""display:none"">
<spam id=""bar"">sometext</span>
<br id=""bun"" />
<div class=""foo"">
<div class=""bar"">
<a href=""baz.php"">baz</a>
</div>
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}