import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<)(br|div)([^>]+?)(\\/?\\s*>)";
final String string = "<br id=\"foo\" style=\"display:none\">\n"
+ "<spam id=\"bar\">sometext</span>\n"
+ "<br id=\"bun\" />\n"
+ "<div class=\"foo\">\n"
+ " <div class=\"bar\">\n"
+ " <a href=\"baz.php\">baz</a>\n"
+ " </div>\n"
+ "</div>";
final String subst = "\\1\\2\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}