// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(<)(br|div)([^>]+?)(\/?\s*>)").unwrap();
let string = "<br id=\"foo\" style=\"display:none\">
<spam id=\"bar\">sometext</span>
<br id=\"bun\" />
<div class=\"foo\">
<div class=\"bar\">
<a href=\"baz.php\">baz</a>
</div>
</div>";
let substitution = "\\1\\2\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}