import Foundation
let pattern = #"(<)(br|div)([^>]+?)(\/?\s*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />
<div class="foo">
<div class="bar">
<a href="baz.php">baz</a>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)