package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(<)(br|div)([^>]+?)(\/?\s*>)`)
var str = `<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />
<div class="foo">
<div class="bar">
<a href="baz.php">baz</a>
</div>
</div>`
var substitution = "\1\2\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}